What’s Vulnerable › Vulnerabilities
CVE-2017-8035
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-07-25 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in the Cloud Controller API in Cloud Foundry Foundation CAPI-release versions after v1.6.0 and prior to v1.35.0 and cf-release versions after v244 and prior to v268. A carefully crafted CAPI request from a Space Developer can allow them to gain access to files on the Cloud Controller VM for that installation.
Affected products
- Cloud Foundry CAPI: from 1.7.0 before 1.35.0 — fixed in 1.35.0
- Cloud Foundry Cloud Controller cf-release versions prior to v255: from 245 before 268 — fixed in 268
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.35.0; Cloud Foundry Cloud Controller cf-release versions prior to v255 268. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-8035 or the next vulnerability affects your stack