What’s Vulnerable › Vulnerabilities

CVE-2017-8046

Description

Malicious PATCH requests submitted to servers using Spring Data REST versions prior to 2.6.9 (Ingalls SR9), versions prior to 3.0.1 (Kay SR1) and Spring Boot versions prior to 1.5.9, 2.0 M6 can use specially crafted JSON data to run arbitrary Java code.

Affected products

How to fix

Upgrade to a fixed version: Spring Boot 1.5.9; Spring Data REST 2.6.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-8046 or the next vulnerability affects your stack