What’s Vulnerable › Vulnerabilities
CVE-2017-8114
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-04-29 · updated 2026-06-17
- Weakness: CWE-269
Description
Roundcube Webmail allows arbitrary password resets by authenticated users. This affects versions before 1.0.11, 1.1.x before 1.1.9, and 1.2.x before 1.2.5. The problem is caused by an improperly restricted exec call in the virtualmin and sasl drivers of the password plugin.
Affected products
- Roundcube Webmail: before 1.0.11; from 1.1.0 before 1.1.9; from 1.2.0 before 1.2.5 — fixed in 1.0.11, 1.1.9, 1.2.5
How to fix
Upgrade to a fixed version: Roundcube Webmail 1.0.11, 1.1.9, 1.2.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/98445
- https://github.com/ilsani/rd/tree/master/security-advisories/web/roundcube/cve-2017-8114
- https://roundcube.net/news/2017/04/28/security-updates-1.2.5-1.1.9-and-1.0.11
- https://security.gentoo.org/glsa/201707-11
- http://www.securityfocus.com/bid/98445
- https://github.com/ilsani/rd/tree/master/security-advisories/web/roundcube/cve-2017-8114
- https://roundcube.net/news/2017/04/28/security-updates-1.2.5-1.1.9-and-1.0.11
- https://security.gentoo.org/glsa/201707-11
Get alerted when CVE-2017-8114 or the next vulnerability affects your stack