What’s Vulnerable › Vulnerabilities
CVE-2017-8325
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-04-29 · updated 2026-06-17
- Weakness: CWE-119
Description
The iw_process_cols_to_intermediate function in imagew-main.c in libimageworsener.a in ImageWorsener before 1.3.1 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted image.
Affected products
- Entropymine Imageworsener: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Entropymine Imageworsener 1.3.1. Check the vendor advisory for mitigations.
References
- https://blogs.gentoo.org/ago/2017/04/27/imageworsener-heap-based-buffer-overflow-in-iw_process_cols_to_intermediate-imagew-main-c/
- https://github.com/jsummers/imageworsener/commit/86564051db45b466e5f667111ce00b5eeedc8fb6
- https://security.gentoo.org/glsa/201706-06
- https://blogs.gentoo.org/ago/2017/04/27/imageworsener-heap-based-buffer-overflow-in-iw_process_cols_to_intermediate-imagew-main-c/
- https://github.com/jsummers/imageworsener/commit/86564051db45b466e5f667111ce00b5eeedc8fb6
- https://security.gentoo.org/glsa/201706-06
Get alerted when CVE-2017-8325 or the next vulnerability affects your stack