What’s Vulnerable › Vulnerabilities
CVE-2017-8540: Microsoft Malware Protection Engine Improper Restriction of Operations Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-03
- EPSS: 71.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-05-26 · updated 2026-06-17
- Weakness: CWE-787
Description
The Microsoft Malware Protection Engine running on Microsoft Forefront and Microsoft Defender on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016, Microsoft Exchange Server 2013 and 2016, does not properly scan a specially crafted file leading to memory corruption. aka "Microsoft Malware Protection Engine Remote Code Execution Vulnerability", a different vulnerability than CVE-2017-8538 and CVE-2017-8541.
Affected products
- Microsoft Endpoint Protection: all versions
- Microsoft Exchange Server: 2013, 2016
- Microsoft Forefront Endpoint Protection: 2010
- Microsoft Forefront Security: all versions
- Microsoft Intune Endpoint Protection: all versions
- Microsoft Malware Protection Engine: from 1.1.13701.0 before 1.1.13704.0 — fixed in 1.1.13704.0
- Microsoft Security Essentials: all versions
- Microsoft System Center Endpoint Protection: all versions
- Microsoft Windows Defender: all versions
How to fix
Upgrade to a fixed version: Microsoft Malware Protection Engine 1.1.13704.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/98703
- http://www.securitytracker.com/id/1038571
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8540
- https://www.exploit-db.com/exploits/42088/
- http://www.securityfocus.com/bid/98703
- http://www.securitytracker.com/id/1038571
- https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8540
- https://www.exploit-db.com/exploits/42088/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2017-8540
Get alerted when CVE-2017-8540 or the next vulnerability affects your stack