What’s Vulnerable › Vulnerabilities

CVE-2017-8797

Description

The NFSv4 server in the Linux kernel before 4.11.3 does not properly validate the layout type when processing the NFSv4 pNFS GETDEVICEINFO or LAYOUTGET operand in a UDP packet from a remote attacker. This type value is uninitialized upon encountering certain error conditions. This value is used as an array index for dereferencing, which leads to an OOPS and eventually a DoS of knfsd and a soft-lockup of the whole system.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.1.40, 4.11.3, 4.4.70, 4.9.30. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-8797 or the next vulnerability affects your stack