What’s Vulnerable › Vulnerabilities
CVE-2017-8807
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-11-16 · updated 2026-06-17
- Weakness: CWE-119
Description
vbf_stp_error in bin/varnishd/cache/cache_fetch.c in Varnish HTTP Cache 4.1.x before 4.1.9 and 5.x before 5.2.1 allows remote attackers to obtain sensitive information from process memory because a VFP_GetStorage buffer is larger than intended in certain circumstances involving -sfile Stevedore transient objects.
Affected products
- Debian Linux: 9.0
- Varnish-Cache Varnish: from 4.1.0 before 4.1.9 — fixed in 4.1.9
- Varnish Cache Project Varnish Cache: from 5.0.0 before 5.2.1 — fixed in 5.2.1
How to fix
Upgrade to a fixed version: Varnish-Cache Varnish 4.1.9; Varnish Cache Project Varnish Cache 5.2.1. Check the vendor advisory for mitigations.
References
- http://varnish-cache.org/security/VSV00002.html
- http://www.securityfocus.com/bid/101886
- https://bugs.debian.org/881808
- https://github.com/varnishcache/varnish-cache/commit/176f8a075a963ffbfa56f1c460c15f6a1a6af5a7
- https://github.com/varnishcache/varnish-cache/pull/2429
- https://www.debian.org/security/2017/dsa-4034
- http://varnish-cache.org/security/VSV00002.html
- http://www.securityfocus.com/bid/101886
- https://bugs.debian.org/881808
- https://github.com/varnishcache/varnish-cache/commit/176f8a075a963ffbfa56f1c460c15f6a1a6af5a7
- https://github.com/varnishcache/varnish-cache/pull/2429
- https://www.debian.org/security/2017/dsa-4034
Get alerted when CVE-2017-8807 or the next vulnerability affects your stack