What’s Vulnerable › Vulnerabilities
CVE-2017-8923
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-05-12 · updated 2026-06-17
- Weakness: CWE-787
Description
The zend_string_extend function in Zend/zend_string.h in PHP through 7.1.5 does not prevent changes to string objects that result in a negative length, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact by leveraging a script's use of .= with a long string.
Affected products
- PHP: before 7.4.24; from 8.0.0 before 8.0.11 — fixed in 7.4.24, 8.0.11
How to fix
Upgrade to a fixed version: PHP 7.4.24, 8.0.11. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/98518
- https://bugs.php.net/bug.php?id=74577
- http://www.securityfocus.com/bid/98518
- https://bugs.php.net/bug.php?id=74577
- https://security.netapp.com/advisory/ntap-20241227-0007/
Get alerted when CVE-2017-8923 or the next vulnerability affects your stack