What’s Vulnerable › Vulnerabilities
CVE-2017-9074
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-05-19 · updated 2026-06-17
- Weakness: CWE-125
Description
The IPv6 fragmentation implementation in the Linux kernel through 4.11.1 does not consider that the nexthdr field may be associated with an invalid option, which allows local users to cause a denial of service (out-of-bounds read and BUG) or possibly have unspecified other impact via crafted socket and send system calls.
Affected products
- Linux kernel: before 3.2.89; from 3.3 before 3.16.44; from 3.17 before 3.18.56; from 3.19 before 4.1.42; from 4.2 before 4.4.71; from 4.5 before 4.9.31 — fixed in 3.16.44, 3.18.56, 3.2.89, 4.1.42, 4.11.4, 4.4.71
How to fix
Upgrade to a fixed version: Linux kernel 3.16.44, 3.18.56, 3.2.89, 4.1.42. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2423496af35d94a87156b063ea5cedffc10a70a1
- http://www.debian.org/security/2017/dsa-3886
- http://www.securityfocus.com/bid/98577
- https://access.redhat.com/errata/RHSA-2017:1842
- https://access.redhat.com/errata/RHSA-2017:2077
- https://access.redhat.com/errata/RHSA-2017:2669
- https://access.redhat.com/errata/RHSA-2018:0169
- https://github.com/torvalds/linux/commit/2423496af35d94a87156b063ea5cedffc10a70a1
- https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+StruxureWare+Data+Center+Expert+v7.6.0
- https://patchwork.ozlabs.org/patch/763117/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2423496af35d94a87156b063ea5cedffc10a70a1
- http://www.debian.org/security/2017/dsa-3886
Get alerted when CVE-2017-9074 or the next vulnerability affects your stack