What’s Vulnerable › Vulnerabilities

CVE-2017-9098

Description

ImageMagick before 7.0.5-2 and GraphicsMagick before 1.3.24 use uninitialized memory in the RLE decoder, allowing an attacker to leak sensitive information from process memory space, as demonstrated by remote attacks against ImageMagick code in a long-running server process that converts image data on behalf of multiple users. This is caused by a missing initialization step in the ReadRLEImage function in coders/rle.c.

Affected products

How to fix

Upgrade to a fixed version: GraphicsMagick 1.3.24; ImageMagick 6.9.8-1, 7.0.5-2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-9098 or the next vulnerability affects your stack