What’s Vulnerable › Vulnerabilities

CVE-2017-9120

Description

PHP 7.x through 7.1.5 allows remote attackers to cause a denial of service (buffer overflow and application crash) or possibly have unspecified other impact via a long string because of an Integer overflow in mysqli_real_escape_string.

Affected products

How to fix

Upgrade to a fixed version: PHP 7.4.23, 8.0.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-9120 or the next vulnerability affects your stack