What’s Vulnerable › Vulnerabilities
CVE-2017-9229
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-05-24 · updated 2026-06-17
- Weakness: CWE-476
Description
An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A SIGSEGV occurs in left_adjust_char_head() during regular expression compilation. Invalid handling of reg->dmax in forward_search_range() could result in an invalid pointer dereference, normally as an immediate denial-of-service condition.
Affected products
- Oniguruma Project Oniguruma: 6.2.0
- PHP: through 7.1.5; from 5.6.0 before 5.6.31; from 7.0.0 before 7.0.21; from 7.1.0 before 7.1.7 — fixed in 5.6.31, 7.0.21, 7.1.7
- Ruby: through 2.4.1
How to fix
Upgrade to a fixed version: PHP 5.6.31, 7.0.21, 7.1.7. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1296
- https://github.com/kkos/oniguruma/commit/b690371bbf97794b4a1d3f295d4fb9a8b05d402d
- https://github.com/kkos/oniguruma/issues/59
- https://access.redhat.com/errata/RHSA-2018:1296
- https://github.com/kkos/oniguruma/commit/b690371bbf97794b4a1d3f295d4fb9a8b05d402d
- https://github.com/kkos/oniguruma/issues/59
Get alerted when CVE-2017-9229 or the next vulnerability affects your stack