What’s Vulnerable › Vulnerabilities
CVE-2017-9462
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 21.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-06-06 · updated 2026-06-17
- Weakness: CWE-732
Description
In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a repository name.
Affected products
- Debian Linux: 8.0, 9.0
- mercurial: before 4.1.3 — fixed in 4.1.3
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.3, 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.3, 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: mercurial 4.1.3. Check the vendor advisory for mitigations.
References
- http://www.debian.org/security/2017/dsa-3963
- http://www.securityfocus.com/bid/99123
- https://access.redhat.com/errata/RHSA-2017:1576
- https://bugs.debian.org/861243
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html
- https://security.gentoo.org/glsa/201709-18
- https://www.mercurial-scm.org/repo/hg/rev/77eaf9539499
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.1.3_.282017-4-18.29
- http://www.debian.org/security/2017/dsa-3963
- http://www.securityfocus.com/bid/99123
- https://access.redhat.com/errata/RHSA-2017:1576
- https://bugs.debian.org/861243
Get alerted when CVE-2017-9462 or the next vulnerability affects your stack