What’s Vulnerable › Vulnerabilities

CVE-2017-9805: Apache Struts Deserialization of Untrusted Data Vulnerability

Description

The REST Plugin in Apache Struts 2.1.1 through 2.3.x before 2.3.34 and 2.5.x before 2.5.13 uses an XStreamHandler with an instance of XStream for deserialization without any type filtering, which can lead to Remote Code Execution when deserializing XML payloads.

Affected products

How to fix

Upgrade to a fixed version: Apache Struts 2.3.34, 2.5.13. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-9805 or the next vulnerability affects your stack