What’s Vulnerable › Vulnerabilities
CVE-2017-9822: DotNetNuke (DNN) Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 94.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-07-20 · updated 2026-06-17
- Weakness: CWE-94
Description
DNN (aka DotNetNuke) before 9.1.1 has Remote Code Execution via a cookie, aka "2017-08 (Critical) Possible remote code execution on DNN sites."
Affected products
- DotNetNuke CMS Fixed in 9.1.1: before 9.1.1 — fixed in 9.1.1
How to fix
Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 9.1.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/157080/DotNetNuke-Cookie-Deserialization-Remote-Code-Execution.html
- http://www.dnnsoftware.com/community/security/security-center
- http://www.securityfocus.com/bid/102213
- http://packetstormsecurity.com/files/157080/DotNetNuke-Cookie-Deserialization-Remote-Code-Execution.html
- http://www.dnnsoftware.com/community/security/security-center
- http://www.securityfocus.com/bid/102213
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2017-9822
Get alerted when CVE-2017-9822 or the next vulnerability affects your stack