What’s Vulnerable › Vulnerabilities
CVE-2017-9841: PHPUnit Command Injection Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-02-15
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-06-27 · updated 2026-06-17
- Weakness: CWE-94
Description
Util/PHP/eval-stdin.php in PHPUnit before 4.8.28 and 5.x before 5.6.3 allows remote attackers to execute arbitrary PHP code via HTTP POST data beginning with a "<?php " substring, as demonstrated by an attack on a site with an exposed /vendor folder, i.e., external access to the /vendor/phpunit/phpunit/src/Util/PHP/eval-stdin.php URI.
Affected products
- Oracle Corporation Communications Diameter Signaling Router (DSR): from 8.0.0 through 8.5.0
- sebastianbergmann phpunit: through 4.8.27; from 5.0.0 before 5.6.3 — fixed in 5.6.3
How to fix
Upgrade to a fixed version: sebastianbergmann phpunit 5.6.3. Check the vendor advisory for mitigations.
References
- http://web.archive.org/web/20170701212357/http://phpunit.vulnbusters.com/
- http://www.securityfocus.com/bid/101798
- http://www.securitytracker.com/id/1039812
- https://github.com/sebastianbergmann/phpunit/commit/284a69fb88a2d0845d23f42974a583d8f59bf5a5
- https://github.com/sebastianbergmann/phpunit/pull/1956
- https://security.gentoo.org/glsa/201711-15
- https://www.oracle.com/security-alerts/cpuoct2021.html
- http://web.archive.org/web/20170701212357/http://phpunit.vulnbusters.com/
- http://www.securityfocus.com/bid/101798
- http://www.securitytracker.com/id/1039812
- https://github.com/sebastianbergmann/phpunit/commit/284a69fb88a2d0845d23f42974a583d8f59bf5a5
- https://github.com/sebastianbergmann/phpunit/pull/1956
Get alerted when CVE-2017-9841 or the next vulnerability affects your stack