What’s Vulnerable › Vulnerabilities
CVE-2017-9984
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-06-28 · updated 2026-06-17
- Weakness: CWE-125
Description
The snd_msnd_interrupt function in sound/isa/msnd/msnd_pinnacle.c in the Linux kernel through 4.11.7 allows local users to cause a denial of service (over-boundary access) or possibly have unspecified other impact by changing the value of a message queue head pointer between two kernel reads of that value, aka a "double fetch" vulnerability.
Affected products
- Linux kernel: before 3.18.71; from 3.19 before 4.1.45; from 4.2 before 4.4.88; from 4.5 before 4.9.50; from 4.10 before 4.12.13 — fixed in 3.18.71, 4.1.45, 4.12.13, 4.4.88, 4.9.50
How to fix
Upgrade to a fixed version: Linux kernel 3.18.71, 4.1.45, 4.12.13, 4.4.88. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=20e2b791796bd68816fa115f12be5320de2b8021
- http://www.securityfocus.com/bid/99314
- https://bugzilla.kernel.org/show_bug.cgi?id=196131
- https://github.com/torvalds/linux/commit/20e2b791796bd68816fa115f12be5320de2b8021
- https://usn.ubuntu.com/3754-1/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=20e2b791796bd68816fa115f12be5320de2b8021
- http://www.securityfocus.com/bid/99314
- https://bugzilla.kernel.org/show_bug.cgi?id=196131
- https://github.com/torvalds/linux/commit/20e2b791796bd68816fa115f12be5320de2b8021
- https://usn.ubuntu.com/3754-1/
Get alerted when CVE-2017-9984 or the next vulnerability affects your stack