What’s Vulnerable › Vulnerabilities

CVE-2017-9992

Description

Heap-based buffer overflow in the decode_dds1 function in libavcodec/dfa.c in FFmpeg before 2.8.12, 3.0.x before 3.0.8, 3.1.x before 3.1.8, 3.2.x before 3.2.5, and 3.3.x before 3.3.1 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted file.

Affected products

How to fix

Upgrade to a fixed version: FFmpeg 2.8.12, 3.0.8, 3.1.8, 3.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-9992 or the next vulnerability affects your stack