What’s Vulnerable › Vulnerabilities

CVE-2017-9993

Description

FFmpeg before 2.8.12, 3.0.x and 3.1.x before 3.1.9, 3.2.x before 3.2.6, and 3.3.x before 3.3.2 does not properly restrict HTTP Live Streaming filename extensions and demuxer names, which allows attackers to read arbitrary files via crafted playlist data.

Affected products

How to fix

Upgrade to a fixed version: FFmpeg 2.8.12, 3.1.9, 3.2.6, 3.3.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-9993 or the next vulnerability affects your stack