What’s Vulnerable › Vulnerabilities
CVE-2018-0167: Cisco IOS, XR, and XE Software Buffer Overflow Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-03-03
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-28 · updated 2026-06-17
- Weakness: CWE-119
Description
Multiple Buffer Overflow vulnerabilities in the Link Layer Discovery Protocol (LLDP) subsystem of Cisco IOS Software, Cisco IOS XE Software, and Cisco IOS XR Software could allow an unauthenticated, adjacent attacker to cause a denial of service (DoS) condition or execute arbitrary code with elevated privileges on an affected device. Cisco Bug IDs: CSCuo17183, CSCvd73487.
Affected products
- Cisco IOS: through 15.6.3m1; through 15.2\(6\)e0a; through 15.2\(4a\)ea5; 5.2.0.base
- Cisco IOS XE: through 15.6.3m1; through 15.2\(6\)e0a; through 15.2\(4a\)ea5; 5.2.0.base
- Cisco IOS XR Software: from 4.1 before 5.1.3 — fixed in 5.1.3
How to fix
Upgrade to a fixed version: Cisco IOS XR Software 5.1.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103564
- http://www.securitytracker.com/id/1040586
- https://ics-cert.us-cert.gov/advisories/ICSA-18-107-03
- https://ics-cert.us-cert.gov/advisories/ICSA-18-107-04
- https://ics-cert.us-cert.gov/advisories/ICSA-18-107-05
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-lldp
- http://www.securityfocus.com/bid/103564
- http://www.securitytracker.com/id/1040586
- https://ics-cert.us-cert.gov/advisories/ICSA-18-107-03
- https://ics-cert.us-cert.gov/advisories/ICSA-18-107-04
- https://ics-cert.us-cert.gov/advisories/ICSA-18-107-05
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-lldp
Get alerted when CVE-2018-0167 or the next vulnerability affects your stack