What’s Vulnerable › Vulnerabilities
CVE-2018-0183
- Severity: medium (CVSS 6.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-28 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the CLI parser of Cisco IOS XE Software could allow an authenticated, local attacker to gain access to the underlying Linux shell of an affected device and execute arbitrary commands with root privileges on the device. The vulnerability is due to the affected software improperly sanitizing command arguments to prevent access to internal data structures on a device. An attacker who has privileged EXEC mode (privilege level 15) access to an affected device could exploit this vulnerability on the device by executing CLI commands that contain crafted arguments. A successful exploit could allow the attacker to gain access to the underlying Linux shell of the affected device and execute arbitrary commands with root privileges on the device. Cisco Bug IDs: CSCuv91356.
Affected products
- Cisco IOS XE: before 3.13.2as; before 3.13.5as; before 3.13.7as; before 3.13.9s; before 3.16.2as; before 3.16.2bs — fixed in 16.3.5b, 16.3.6, 16.6.3, 3.13.0as, 3.13.2as, 3.13.5as
How to fix
Upgrade to a fixed version: Cisco IOS XE 16.3.5b, 16.3.6, 16.6.3, 3.13.0as. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103555
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-privesc3
- http://www.securityfocus.com/bid/103555
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-privesc3
Get alerted when CVE-2018-0183 or the next vulnerability affects your stack