What’s Vulnerable › Vulnerabilities
CVE-2018-0188
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple vulnerabilities in the web-based user interface (web UI) of Cisco IOS XE Software could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web UI of the affected software. The vulnerabilities are due to insufficient input validation of certain parameters that are passed to the affected software via the web UI. An attacker could exploit these vulnerabilities by persuading a user of the affected UI to access a malicious link or by intercepting a user request for the affected UI and injecting malicious code into the request. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected UI or allow the attacker to access sensitive browser-based information on the user's system. Cisco Bug IDs: CSCuz38591, CSCvb09530, CSCvb10022.
Affected products
- Cisco IOS XE: before 16.3.6 — fixed in 16.3.6
How to fix
Upgrade to a fixed version: Cisco IOS XE 16.3.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103551
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-webuixss
- http://www.securityfocus.com/bid/103551
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-webuixss
Get alerted when CVE-2018-0188 or the next vulnerability affects your stack