What’s Vulnerable › Vulnerabilities
CVE-2018-0195
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-28 · updated 2026-06-17
- Weakness: CWE-287
Description
A vulnerability in the Cisco IOS XE Software REST API could allow an authenticated, remote attacker to bypass API authorization checks and use the API to perform privileged actions on an affected device. The vulnerability is due to insufficient authorization checks for requests that are sent to the REST API of the affected software. An attacker could exploit this vulnerability by sending a malicious request to an affected device via the REST API. A successful exploit could allow the attacker to selectively bypass authorization checks for the REST API of the affected software and use the API to perform privileged actions on an affected device. Cisco Bug IDs: CSCuz56428.
Affected products
- Cisco IOS XE: before 16.2.2 — fixed in 16.2.2
How to fix
Upgrade to a fixed version: Cisco IOS XE 16.2.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103557
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-rest
- http://www.securityfocus.com/bid/103557
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180328-rest
Get alerted when CVE-2018-0195 or the next vulnerability affects your stack