What’s Vulnerable › Vulnerabilities
CVE-2018-0228
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-19 · updated 2026-08-11
- Weakness: CWE-20
Description
A vulnerability in the ingress flow creation functionality of Cisco Adaptive Security Appliance (ASA) could allow an unauthenticated, remote attacker to cause the CPU to increase upwards of 100% utilization, causing a denial of service (DoS) condition on an affected system. The vulnerability is due to incorrect handling of an internal software lock that could prevent other system processes from getting CPU cycles, causing a high CPU condition. An attacker could exploit this vulnerability by sending a steady stream of malicious IP packets that can cause connections to be created on the targeted device. A successful exploit could allow the attacker to exhaust CPU resources, resulting in a DoS condition during which traffic through the device could be delayed. This vulnerability applies to either IPv4 or IPv6 ingress traffic. This vulnerability affects Cisco Adaptive Security Appliance (ASA) and Firepower Threat Defense (FTD) Software that is running on the following Cisco products: 3000 Series Industrial Security Appliances (ISA), ASA 5500 Series Adaptive Security Appliances, ASA 5500-X Series Next-Generation Firewalls, ASA Services Module for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers, Adaptive Security Virtual Appliances (ASAv), Firepower 2100 Series Security Appliances, Firepower 4110 Security Appliances, Firepower 9300 ASA Security Modules. Cisco Bug IDs: CSCvf63718.
Affected products
- Cisco ASA Software: from 9.1 before 9.1.7.20; from 9.3 before 9.4.4.13; from 9.5 before 9.6.3.17; from 9.7 before 9.7.1.16; from 9.8 before 9.8.2.14; from 9.2 before 9.2.4.27 — fixed in 9.1.7.20, 9.2.4.27, 9.4.4.13, 9.6.3.17, 9.7.1.16, 9.8.2.14
- Cisco Firepower Threat Defense Software: from 6.0 before 6.1.0.6; from 6.2.0 before 6.2.0.5; from 6.2.1 before 6.2.2.2 — fixed in 6.1.0.6, 6.2.0.5, 6.2.2.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.1.7.20, 9.2.4.27, 9.4.4.13, 9.6.3.17; Cisco Firepower Threat Defense Software 6.1.0.6, 6.2.0.5, 6.2.2.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104220
- http://www.securitytracker.com/id/1040724
- https://ics-cert.us-cert.gov/advisories/ICSA-18-184-01
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180418-asa2
- http://www.securityfocus.com/bid/104220
- http://www.securitytracker.com/id/1040724
- https://ics-cert.us-cert.gov/advisories/ICSA-18-184-01
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180418-asa2
Get alerted when CVE-2018-0228 or the next vulnerability affects your stack