What’s Vulnerable › Vulnerabilities
CVE-2018-0240
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-19 · updated 2026-08-11
- Weakness: CWE-399
Description
Multiple vulnerabilities in the Application Layer Protocol Inspection feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to trigger a reload of an affected device, resulting in a denial of service (DoS) condition. The vulnerabilities are due to logical errors during traffic inspection. An attacker could exploit these vulnerabilities by sending a high volume of malicious traffic across an affected device. An exploit could allow the attacker to cause a deadlock condition, resulting in a reload of an affected device. These vulnerabilities affect Cisco ASA Software and Cisco FTD Software configured for Application Layer Protocol Inspection running on the following Cisco products: 3000 Series Industrial Security Appliance (ISA), ASA 5500 Series Adaptive Security Appliances, ASA 5500-X Series Next-Generation Firewalls, ASA Services Module for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers, Adaptive Security Virtual Appliance (ASAv), Firepower 2100 Series Security Appliance, Firepower 4100 Series Security Appliance, Firepower 9300 ASA Security Module, FTD Virtual (FTDv). Cisco Bug IDs: CSCve61540, CSCvh23085, CSCvh95456.
Affected products
- Cisco ASA Software: from 9.6.0.0 before 9.6.4.6; from 9.7.0.0 before 9.7.1.24; from 9.8.0.0 before 9.8.2.24; from 9.9.0.0 before 9.9.1.4 — fixed in 9.6.4.6, 9.7.1.24, 9.8.2.24, 9.9.1.4
- Cisco Firepower Threat Defense Software: from 6.1.0 through 6.1.0.7; from 6.2.0 before 6.2.0.5; from 6.2.1 before 6.2.2.2 — fixed in 6.2.0.5, 6.2.2.2
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.6.4.6, 9.7.1.24, 9.8.2.24, 9.9.1.4; Cisco Firepower Threat Defense Software 6.2.0.5, 6.2.2.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103934
- http://www.securitytracker.com/id/1040722
- https://ics-cert.us-cert.gov/advisories/ICSA-18-184-01
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180418-asa_inspect
- http://www.securityfocus.com/bid/103934
- http://www.securitytracker.com/id/1040722
- https://ics-cert.us-cert.gov/advisories/ICSA-18-184-01
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180418-asa_inspect
Get alerted when CVE-2018-0240 or the next vulnerability affects your stack