What’s Vulnerable › Vulnerabilities
CVE-2018-0298
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-21 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the web UI of Cisco FXOS and Cisco UCS Fabric Interconnect Software could allow an unauthenticated, remote attacker to cause a buffer overflow on an affected system. The vulnerability is due to incorrect input validation in the web UI. An attacker could exploit this vulnerability by sending a malicious HTTP or HTTPS packet directed to the physical management interface of an affected system. A successful exploit could allow the attacker to cause the process to crash and possibly reload the device, resulting in a denial of service (DoS) condition on the affected system. This vulnerability affects Firepower 4100 Series Next-Generation Firewall, Firepower 9300 Security Appliance, UCS 6200 Series Fabric Interconnects, UCS 6300 Series Fabric Interconnects. Cisco Bug IDs: CSCvb61398, CSCvb86799.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): from 1.1 before 1.1.4.169; from 2.0 before 2.0.1.135; from 1.1 before 1.1.4.179; from 2.0 before 2.0.1.153 — fixed in 1.1.4.169, 1.1.4.179, 2.0.1.135, 2.0.1.153
- Cisco NX-OS: from 3.0\(2\) before 3.1\(3a\)a — fixed in 3.1\(3a\)a
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 1.1.4.169, 1.1.4.179, 2.0.1.135, 2.0.1.153; Cisco NX-OS 3.1\(3a\)a. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fxos-dos
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fxos-dos
Get alerted when CVE-2018-0298 or the next vulnerability affects your stack