What’s Vulnerable › Vulnerabilities
CVE-2018-0302
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-21 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the CLI parser of Cisco FXOS Software and Cisco UCS Fabric Interconnect Software could allow an authenticated, local attacker to cause a buffer overflow on an affected device. The vulnerability is due to incorrect input validation in the CLI parser subsystem. An attacker could exploit this vulnerability by exceeding the expected length of user input. A successful exploit could allow the attacker to execute arbitrary code with root privileges on the affected system. This vulnerability affects Firepower 4100 Series Next-Generation Firewall, Firepower 9300 Security Appliance, UCS 6100 Series Fabric Interconnects, UCS 6200 Series Fabric Interconnects, UCS 6300 Series Fabric Interconnects. Cisco Bug IDs: CSCvb61099, CSCvb86743.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): from 1.1 before 1.1.4.169; from 2.0 before 2.0.1.135 — fixed in 1.1.4.169, 2.0.1.135
- Cisco NX-OS: 3.1(1k)a
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 1.1.4.169, 2.0.1.135. Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fxos-ace
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-fxos-ace
Get alerted when CVE-2018-0302 or the next vulnerability affects your stack