What’s Vulnerable › Vulnerabilities
CVE-2018-0360
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-16 · updated 2026-06-17
- Weakness: CWE-190
Description
ClamAV before 0.100.1 has an HWP integer overflow with a resultant infinite loop via a crafted Hangul Word Processor file. This is in parsehwp3_paragraph() in libclamav/hwp.c.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Cisco ClamAV: before 0.100.1 — fixed in 0.100.1
- Debian Linux: 8.0
How to fix
Upgrade to a fixed version: Cisco ClamAV 0.100.1. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1041367
- https://blog.clamav.net/2018/07/clamav-01001-has-been-released.html
- https://lists.debian.org/debian-lts-announce/2018/08/msg00020.html
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-12/
- https://security.gentoo.org/glsa/201904-12
- https://usn.ubuntu.com/3722-1/
- https://usn.ubuntu.com/3722-2/
- http://www.securitytracker.com/id/1041367
- https://blog.clamav.net/2018/07/clamav-01001-has-been-released.html
- https://lists.debian.org/debian-lts-announce/2018/08/msg00020.html
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-12/
- https://security.gentoo.org/glsa/201904-12
Get alerted when CVE-2018-0360 or the next vulnerability affects your stack