What’s Vulnerable › Vulnerabilities
CVE-2018-0417: Cisco Wireless LAN Controller Software GUI Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-17 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in TACACS authentication with Cisco Wireless LAN Controller (WLC) Software could allow an authenticated, local attacker to perform certain operations within the GUI that are not normally available to that user on the CLI. The vulnerability is due to incorrect parsing of a specific TACACS attribute received in the TACACS response from the remote TACACS server. An attacker could exploit this vulnerability by authenticating via TACACS to the GUI on the affected device. A successful exploit could allow an attacker to create local user accounts with administrative privileges on an affected WLC and execute other commands that are not allowed from the CLI and should be prohibited.
Affected products
- Cisco Wireless Lan Controller: from 8.4 before 8.5.131.0 — fixed in 8.5.131.0
- Cisco Wireless LAN Controller (WLC): before 8.2.170.0; from 8.6 before 8.7.102.0; 8.7(1.115) — fixed in 8.2.170.0, 8.7.102.0
How to fix
Upgrade to a fixed version: Cisco Wireless Lan Controller 8.5.131.0; Cisco Wireless LAN Controller (WLC) 8.2.170.0, 8.7.102.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105667
- http://www.securitytracker.com/id/1041924
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20181017-wlc-gui-privesc
- http://www.securityfocus.com/bid/105667
- http://www.securitytracker.com/id/1041924
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20181017-wlc-gui-privesc
Get alerted when CVE-2018-0417 or the next vulnerability affects your stack