What’s Vulnerable › Vulnerabilities
CVE-2018-0424: Cisco RV110W, RV130W, and RV215W Routers Management Interface Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-05 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the web-based management interface of the Cisco RV110W Wireless-N VPN Firewall, Cisco RV130W Wireless-N Multifunction VPN Router, and Cisco RV215W Wireless-N VPN Router could allow an authenticated, remote attacker to execute arbitrary commands. The vulnerability is due to improper validation of user-supplied input to scripts by the web-based management interface. An attacker could exploit this vulnerability by sending malicious requests to a targeted device. A successful exploit could allow the attacker to execute arbitrary commands with the privileges of the root user.
Affected products
- Cisco Rv110W Firmware: through 1.2.1.7
- Cisco Rv130W Firmware: before 1.0.3.44 — fixed in 1.0.3.44
- Cisco Rv215W Firmware: through 1.3.0.8
How to fix
Upgrade to a fixed version: Cisco Rv130W Firmware 1.0.3.44. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1041677
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180905-rv-routers-injection
- http://www.securitytracker.com/id/1041677
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180905-rv-routers-injection
Get alerted when CVE-2018-0424 or the next vulnerability affects your stack