What’s Vulnerable › Vulnerabilities
CVE-2018-0433: Cisco SD-WAN Solution Command Injection Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-05 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the command-line interface (CLI) in the Cisco SD-WAN Solution could allow an authenticated, local attacker to inject arbitrary commands that are executed with root privileges. The vulnerability is due to insufficient input validation. An attacker could exploit this vulnerability by authenticating to the device and submitting crafted input to the CLI utility. The attacker must be authenticated to access the CLI utility. A successful exploit could allow the attacker to execute commands with root privileges.
Affected products
- Cisco Vbond Orchestrator: all versions
- Cisco Vedge 1000 Firmware: before 18.3.0 — fixed in 18.3.0
- Cisco Vedge 100 Firmware: before 18.3.0 — fixed in 18.3.0
- Cisco Vedge 2000 Firmware: before 18.3.0 — fixed in 18.3.0
- Cisco Vedge 5000 Firmware: before 18.3.0 — fixed in 18.3.0
- Cisco Vedge Cloud Router Platform: all versions
- Cisco Vmanage Network Management System: all versions
- Cisco Vsmart Controller: all versions
How to fix
Upgrade to a fixed version: Cisco Vedge 1000 Firmware 18.3.0; Cisco Vedge 100 Firmware 18.3.0; Cisco Vedge 2000 Firmware 18.3.0; Cisco Vedge 5000 Firmware 18.3.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105295
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180905-sd-wan-injection
- http://www.securityfocus.com/bid/105295
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180905-sd-wan-injection
Get alerted when CVE-2018-0433 or the next vulnerability affects your stack