What’s Vulnerable › Vulnerabilities

CVE-2018-0487

Description

ARM mbed TLS before 1.3.22, before 2.1.10, and before 2.7.0 allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow) via a crafted certificate chain that is mishandled during RSASSA-PSS signature verification within a TLS or DTLS session.

Affected products

How to fix

Upgrade to a fixed version: mbedtls 1.3.22, 2.1.10, 2.7.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-0487 or the next vulnerability affects your stack