What’s Vulnerable › Vulnerabilities
CVE-2018-0488
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-13 · updated 2026-06-17
- Weakness: CWE-787
Description
ARM mbed TLS before 1.3.22, before 2.1.10, and before 2.7.0, when the truncated HMAC extension and CBC are used, allows remote attackers to execute arbitrary code or cause a denial of service (heap corruption) via a crafted application packet within a TLS or DTLS session.
Affected products
- mbedtls: from 1.3.0 before 1.3.22; from 2.1.0 before 2.1.10; from 2.2.0 before 2.7.0 — fixed in 1.3.22, 2.1.10, 2.7.0
- Debian Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: mbedtls 1.3.22, 2.1.10, 2.7.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103057
- https://security.gentoo.org/glsa/201804-19
- https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-01
- https://usn.ubuntu.com/4267-1/
- https://www.debian.org/security/2018/dsa-4138
- https://www.debian.org/security/2018/dsa-4147
- http://www.securityfocus.com/bid/103057
- https://security.gentoo.org/glsa/201804-19
- https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2018-01
- https://usn.ubuntu.com/4267-1/
- https://www.debian.org/security/2018/dsa-4138
- https://www.debian.org/security/2018/dsa-4147
Get alerted when CVE-2018-0488 or the next vulnerability affects your stack