What’s Vulnerable › Vulnerabilities
CVE-2018-0493
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-03 · updated 2026-06-17
- Weakness: CWE-416
Description
remctld in remctl before 3.14, when an attacker is authorized to execute a command that uses the sudo option, has a use-after-free that leads to a daemon crash, memory corruption, or arbitrary command execution.
Affected products
- Debian Linux: 9.0
- Eyrie Remctl: before 3.14 — fixed in 3.14
How to fix
Upgrade to a fixed version: Eyrie Remctl 3.14. Check the vendor advisory for mitigations.
References
- https://git.eyrie.org/?p=kerberos/remctl.git%3Ba=commit%3Bh=86c7e44090c988112a37589d2c7a94029eb5e641
- https://www.debian.org/security/2018/dsa-4159
- https://www.eyrie.org/~eagle/software/remctl/security/2018-04-01.html
- https://git.eyrie.org/?p=kerberos/remctl.git%3Ba=commit%3Bh=86c7e44090c988112a37589d2c7a94029eb5e641
- https://www.debian.org/security/2018/dsa-4159
- https://www.eyrie.org/~eagle/software/remctl/security/2018-04-01.html
Get alerted when CVE-2018-0493 or the next vulnerability affects your stack