What’s Vulnerable › Vulnerabilities
CVE-2018-0494
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-06 · updated 2026-06-17
- Weakness: CWE-20
Description
GNU Wget before 1.19.5 is prone to a cookie injection vulnerability in the resp_new function in http.c via a \r\n sequence in a continuation line.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- gnuwget wget: before 1.19.5 — fixed in 1.19.5
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: gnuwget wget 1.19.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104129
- http://www.securitytracker.com/id/1040838
- https://access.redhat.com/errata/RHSA-2018:3052
- https://git.savannah.gnu.org/cgit/wget.git/commit/?id=1fc9c95ec144499e69dc8ec76dbe07799d7d82cd
- https://lists.debian.org/debian-lts-announce/2018/05/msg00006.html
- https://lists.gnu.org/archive/html/bug-wget/2018-05/msg00020.html
- https://savannah.gnu.org/bugs/?53763
- https://security.gentoo.org/glsa/201806-01
- https://sintonen.fi/advisories/gnu-wget-cookie-injection.txt
- https://usn.ubuntu.com/3643-1/
- https://usn.ubuntu.com/3643-2/
- https://www.debian.org/security/2018/dsa-4195
Get alerted when CVE-2018-0494 or the next vulnerability affects your stack