What’s Vulnerable › Vulnerabilities
CVE-2018-0502
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-05 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in zsh before 5.6. The beginning of a #! script file was mishandled, potentially leading to an execve call to a program named on the second line.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- zsh: before 5.6 — fixed in 5.6
How to fix
Upgrade to a fixed version: zsh 5.6. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/908000
- https://lists.debian.org/debian-lts-announce/2020/12/msg00000.html
- https://security.gentoo.org/glsa/201903-02
- https://sourceforge.net/p/zsh/code/ci/1c4c7b6a4d17294df028322b70c53803a402233d
- https://usn.ubuntu.com/3764-1/
- https://www.zsh.org/mla/zsh-announce/136
- https://bugs.debian.org/908000
- https://lists.debian.org/debian-lts-announce/2020/12/msg00000.html
- https://security.gentoo.org/glsa/201903-02
- https://sourceforge.net/p/zsh/code/ci/1c4c7b6a4d17294df028322b70c53803a402233d
- https://usn.ubuntu.com/3764-1/
- https://www.zsh.org/mla/zsh-announce/136
Get alerted when CVE-2018-0502 or the next vulnerability affects your stack