What’s Vulnerable › Vulnerabilities

CVE-2018-0679

Description

Cross-site scripting vulnerability in multiple FXC Inc. network devices (Managed Ethernet switch FXC5210/5218/5224 firmware prior to version Ver1.00.22, Managed Ethernet switch FXC5426F firmware prior to version Ver1.00.06, Managed Ethernet switch FXC5428 firmware prior to version Ver1.00.07, Power over Ethernet (PoE) switch FXC5210PE/5218PE/5224PE firmware prior to version Ver1.00.14, and Wireless LAN router AE1021/AE1021PE firmware all versions) allows attacker with administrator rights to inject arbitrary web script or HTML via the administrative page.

Affected products

How to fix

Upgrade to a fixed version: Fxc5210 Firmware 1.00.22; Fxc5210Pe Firmware 1.00.14; Fxc5218 Firmware 1.00.22; Fxc5218Pe Firmware 1.00.14; Fxc5224 Firmware 1.00.22; Fxc5224Pe Firmware 1.00.14; Fxc5426F Firmware 1.00.06; Fxc5428 Firmware 1.00.07. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-0679 or the next vulnerability affects your stack