What’s Vulnerable › Vulnerabilities
CVE-2018-0739: Constructed ASN.1 types with a recursive definition could exceed the stack
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-27 · updated 2026-06-17
- Weakness: CWE-674
Description
Constructed ASN.1 types with a recursive definition (such as can be found in PKCS7) could eventually exceed the stack given malicious input with excessive recursion. This could result in a Denial Of Service attack. There are no such structures used within SSL/TLS that come from untrusted sources so this is considered safe. Fixed in OpenSSL 1.1.0h (Affected 1.1.0-1.1.0g). Fixed in OpenSSL 1.0.2o (Affected 1.0.2b-1.0.2n).
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- OpenSSL: from 1.0.2b through 1.0.2n; from 1.1.0 through 1.1.0g
References
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- http://www.oracle.com/technetwork/security-advisory/cpujul2018-4258247.html
- http://www.oracle.com/technetwork/security-advisory/cpuoct2018-4428296.html
- http://www.securityfocus.com/bid/103518
- http://www.securityfocus.com/bid/105609
- http://www.securitytracker.com/id/1040576
- https://access.redhat.com/errata/RHSA-2018:3090
- https://access.redhat.com/errata/RHSA-2018:3221
- https://access.redhat.com/errata/RHSA-2018:3505
- https://access.redhat.com/errata/RHSA-2019:0366
- https://access.redhat.com/errata/RHSA-2019:0367
- https://access.redhat.com/errata/RHSA-2019:1711
Get alerted when CVE-2018-0739 or the next vulnerability affects your stack