What’s Vulnerable › Vulnerabilities
CVE-2018-1000025
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
- Weakness: CWE-732
Description
Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.
Affected products
- Firebase Admin Sdk For Php Project Firebase Admin Sdk For Php: from 3.2.0 through 3.8.0
References
- https://github.com/kreait/firebase-php/pull/151
- https://github.com/kreait/firebase-php/releases/tag/3.8.1
- https://github.com/kreait/firebase-php/pull/151
- https://github.com/kreait/firebase-php/releases/tag/3.8.1
Get alerted when CVE-2018-1000025 or the next vulnerability affects your stack