What’s Vulnerable › Vulnerabilities
CVE-2018-1000026
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
- Weakness: CWE-20
Description
Linux Linux kernel version at least v4.8 onwards, probably well before contains a Insufficient input validation vulnerability in bnx2x network card driver that can result in DoS: Network card firmware assertion takes card off-line. This attack appear to be exploitable via An attacker on a must pass a very large, specially crafted packet to the bnx2x card. This can be done from an untrusted guest VM..
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 8.0
- Linux kernel: from 2.6.12 before 4.4.181; from 4.5.0 before 4.9.159; from 4.10 before 4.14.102; from 4.15 before 4.16 — fixed in 4.14.102, 4.16, 4.4.181, 4.9.159
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.102, 4.16, 4.4.181, 4.9.159. Check the vendor advisory for mitigations.
References
- http://lists.openwall.net/netdev/2018/01/16/40
- http://lists.openwall.net/netdev/2018/01/18/96
- https://access.redhat.com/errata/RHSA-2018:2948
- https://access.redhat.com/errata/RHSA-2018:3083
- https://access.redhat.com/errata/RHSA-2018:3096
- https://lists.debian.org/debian-lts-announce/2019/05/msg00002.html
- https://patchwork.ozlabs.org/patch/859410/
- https://usn.ubuntu.com/3617-1/
- https://usn.ubuntu.com/3617-2/
- https://usn.ubuntu.com/3617-3/
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
Get alerted when CVE-2018-1000026 or the next vulnerability affects your stack