What’s Vulnerable › Vulnerabilities
CVE-2018-1000027
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 12.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
- Weakness: CWE-476
Description
The Squid Software Foundation Squid HTTP Caching Proxy version prior to version 4.0.23 contains a NULL Pointer Dereference vulnerability in HTTP Response X-Forwarded-For header processing that can result in Denial of Service to all clients of the proxy. This attack appear to be exploitable via Remote HTTP server responding with an X-Forwarded-For header to certain types of HTTP request. This vulnerability appears to have been fixed in 4.0.23 and later.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Squid: before 4.0.23 — fixed in 4.0.23
How to fix
Upgrade to a fixed version: Squid 4.0.23. Check the vendor advisory for mitigations.
References
- http://www.squid-cache.org/Advisories/SQUID-2018_2.txt
- http://www.squid-cache.org/Versions/v3/3.5/changesets/SQUID-2018_2.patch
- http://www.squid-cache.org/Versions/v4/changesets/SQUID-2018_2.patch
- https://github.com/squid-cache/squid/pull/129/files
- https://lists.debian.org/debian-lts-announce/2018/02/msg00001.html
- https://lists.debian.org/debian-lts-announce/2018/02/msg00002.html
- https://usn.ubuntu.com/3557-1/
- https://usn.ubuntu.com/4059-2/
- https://www.debian.org/security/2018/dsa-4122
- http://www.squid-cache.org/Advisories/SQUID-2018_2.txt
- http://www.squid-cache.org/Versions/v3/3.5/changesets/SQUID-2018_2.patch
- http://www.squid-cache.org/Versions/v4/changesets/SQUID-2018_2.patch
Get alerted when CVE-2018-1000027 or the next vulnerability affects your stack