What’s Vulnerable › Vulnerabilities
CVE-2018-1000041
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
Description
GNOME librsvg version before commit c6ddf2ed4d768fd88adbea2b63f575cd523022ea contains a Improper input validation vulnerability in rsvg-io.c that can result in the victim's Windows username and NTLM password hash being leaked to remote attackers through SMB. This attack appear to be exploitable via The victim must process a specially crafted SVG file containing an UNC path on Windows.
Affected products
- Debian Linux: 7.0
- GNOME Librsvg: before 2.41.2 — fixed in 2.41.2
How to fix
Upgrade to a fixed version: GNOME Librsvg 2.41.2. Check the vendor advisory for mitigations.
References
- https://github.com/GNOME/librsvg/commit/c6ddf2ed4d768fd88adbea2b63f575cd523022ea
- https://github.com/ImageMagick/librsvg/commit/f9d69eadd2b16b00d1a1f9f286122123f8e547dd
- https://lists.debian.org/debian-lts-announce/2018/02/msg00013.html
- https://github.com/GNOME/librsvg/commit/c6ddf2ed4d768fd88adbea2b63f575cd523022ea
- https://github.com/ImageMagick/librsvg/commit/f9d69eadd2b16b00d1a1f9f286122123f8e547dd
- https://lists.debian.org/debian-lts-announce/2018/02/msg00013.html
Get alerted when CVE-2018-1000041 or the next vulnerability affects your stack