What’s Vulnerable › Vulnerabilities
CVE-2018-1000050
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
- Weakness: CWE-119
Description
Sean Barrett stb_vorbis version 1.12 and earlier contains a Buffer Overflow vulnerability in All vorbis decoding paths. that can result in memory corruption, denial of service, comprised execution of host program. This attack appear to be exploitable via Victim must open a specially crafted Ogg Vorbis file. This vulnerability appears to have been fixed in 1.13.
Affected products
- Stb Vorbis Project Stb Vorbis: through 1.12
References
- https://github.com/nothings/stb/commit/244d83bc3d859293f55812d48b3db168e581f6ab
- https://github.com/nothings/stb/commit/244d83bc3d859293f55812d48b3db168e581f6ab
Get alerted when CVE-2018-1000050 or the next vulnerability affects your stack