What’s Vulnerable › Vulnerabilities
CVE-2018-1000060
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-09 · updated 2026-06-17
- Weakness: CWE-532
Description
Sensu, Inc. Sensu Core version Before 1.2.0 & before commit 46ff10023e8cbf1b6978838f47c51b20b98fe30b contains a CWE-522 vulnerability in Sensu::Utilities.redact_sensitive() that can result in sensitive configuration data (e.g. passwords) may be logged in clear-text. This attack appear to be exploitable via victims with configuration matching a specific pattern will observe sensitive data outputted in their service log files. This vulnerability appears to have been fixed in 1.2.1 and later, after commit 46ff10023e8cbf1b6978838f47c51b20b98fe30b.
Affected products
- Sensu Core: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Sensu Core 1.2.1. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:0616
- https://access.redhat.com/errata/RHSA-2018:1112
- https://access.redhat.com/errata/RHSA-2018:1606
- https://github.com/sensu/sensu/issues/1804
- https://github.com/sensu/sensu/pull/1810
- https://access.redhat.com/errata/RHSA-2018:0616
- https://access.redhat.com/errata/RHSA-2018:1112
- https://access.redhat.com/errata/RHSA-2018:1606
- https://github.com/sensu/sensu/issues/1804
- https://github.com/sensu/sensu/pull/1810
Get alerted when CVE-2018-1000060 or the next vulnerability affects your stack