What’s Vulnerable › Vulnerabilities
CVE-2018-1000086
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-13 · updated 2026-06-17
- Weakness: CWE-352
Description
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Affected products
- Npr Pym.Js: from 0.4.2 through 1.3.1
References
- http://blog.apps.npr.org/2018/02/15/pym-security-vulnerability.html
- https://github.com/nprapps/pym.js
- https://github.com/nprapps/pym.js/issues/170
- http://blog.apps.npr.org/2018/02/15/pym-security-vulnerability.html
- https://github.com/nprapps/pym.js
- https://github.com/nprapps/pym.js/issues/170
Get alerted when CVE-2018-1000086 or the next vulnerability affects your stack