What’s Vulnerable › Vulnerabilities
CVE-2018-1000127
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-13 · updated 2026-06-17
- Weakness: CWE-190
Description
memcached version prior to 1.4.37 contains an Integer Overflow vulnerability in items.c:item_free() that can result in data corruption and deadlocks due to items existing in hash table being reused from free list. This attack appear to be exploitable via network connectivity to the memcached service. This vulnerability appears to have been fixed in 1.4.37 and later.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Memcached: before 1.4.37 — fixed in 1.4.37
- OpenStack: 10
How to fix
Upgrade to a fixed version: Memcached 1.4.37. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2290
- https://github.com/memcached/memcached/commit/a8c4a82787b8b6c256d61bd5c42fb7f92d1bae00
- https://github.com/memcached/memcached/issues/271
- https://github.com/memcached/memcached/wiki/ReleaseNotes1437
- https://lists.debian.org/debian-lts-announce/2018/03/msg00031.html
- https://usn.ubuntu.com/3601-1/
- https://www.debian.org/security/2018/dsa-4218
- https://access.redhat.com/errata/RHSA-2018:2290
- https://github.com/memcached/memcached/commit/a8c4a82787b8b6c256d61bd5c42fb7f92d1bae00
- https://github.com/memcached/memcached/issues/271
- https://github.com/memcached/memcached/wiki/ReleaseNotes1437
- https://lists.debian.org/debian-lts-announce/2018/03/msg00031.html
Get alerted when CVE-2018-1000127 or the next vulnerability affects your stack