What’s Vulnerable › Vulnerabilities
CVE-2018-1000162
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.
Affected products
- Parsedown: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: Parsedown 1.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/Roave/SecurityAdvisories/issues/44#issuecomment-368594409
- https://github.com/erusev/parsedown/pull/495
- https://github.com/Roave/SecurityAdvisories/issues/44#issuecomment-368594409
- https://github.com/erusev/parsedown/pull/495
Get alerted when CVE-2018-1000162 or the next vulnerability affects your stack