What’s Vulnerable › Vulnerabilities
CVE-2018-1000165
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-18 · updated 2026-06-17
- Weakness: CWE-732
Description
LightSAML version prior to 1.3.5 contains a Incorrect Access Control vulnerability in signature validation in readers in src/LightSaml/Model/XmlDSig/ that can result in impersonation of any user from Identity Provider. This vulnerability appears to have been fixed in 1.3.5 and later.
Affected products
- Lightsaml: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: Lightsaml 1.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/lightSAML/lightSAML/commit/47cef07bb09779df15620799f3763d1b8d32307a
- https://github.com/lightSAML/lightSAML/releases/tag/1.3.5
- https://github.com/lightSAML/lightSAML/commit/47cef07bb09779df15620799f3763d1b8d32307a
- https://github.com/lightSAML/lightSAML/releases/tag/1.3.5
Get alerted when CVE-2018-1000165 or the next vulnerability affects your stack