What’s Vulnerable › Vulnerabilities
CVE-2018-1000180
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-05 · updated 2026-06-17
- Weakness: CWE-327
Description
Bouncy Castle BC 1.54 - 1.59, BC-FJA 1.0.0, BC-FJA 1.0.1 and earlier have a flaw in the Low-level interface to RSA key pair generator, specifically RSA Key Pairs generated in low-level API with added certainty may have less M-R tests than expected. This appears to be fixed in versions BC 1.60 beta 4 and later, BC-FJA 1.0.2 and later.
Affected products
- Legion of the Bouncy Castle Inc. BC-JAVA: from 1.54 through 1.59
- Bouncycastle Fips Java Api: through 1.0.1
- Debian Linux: 9.0
- NetApp OnCommand Workflow Automation: all versions
- Oracle Corporation API Gateway: 11.1.2.4.0
- Oracle Corporation Oracle Business Process Management Suite: 11.1.1.9.0, 12.1.3.0.0, 12.2.1.3.0
- Oracle Business Transaction Management: 12.1.0
- Oracle Communications Application Session Controller: 3.7.1, 3.8.0
- Oracle Corporation Oracle Communications Converged Application Server: before 7.0.0.1 — fixed in 7.0.0.1
- Oracle Corporation Communications WebRTC Session Controller: before 7.2 — fixed in 7.2
- Oracle Corporation Enterprise Repository: 12.1.3.0.0
- Oracle Corporation Oracle Managed File Transfer: 12.1.3.0.0, 12.2.1.3.0
- Oracle Corporation PeopleSoft Enterprise PT PeopleTools: 8.55, 8.56, 8.57
- Oracle Retail Convenience And Fuel Pos Software: 2.8.1
- Oracle Corporation Retail Xstore Point of Service: 7.0, 7.1
- Oracle Corporation Oracle SOA Suite: 12.1.3.0.0, 12.2.1.3.0
- Oracle Corporation Oracle WebCenter Portal: 11.1.1.9.0, 12.2.1.3.0
- Oracle WebLogic Server: 12.1.3.0.0
- Red Hat JBoss EAP: 7.1.0
- RedHat Virtualization: 4.2
How to fix
Upgrade to a fixed version: Oracle Corporation Oracle Communications Converged Application Server 7.0.0.1; Oracle Corporation Communications WebRTC Session Controller 7.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106567
- https://access.redhat.com/errata/RHSA-2018:2423
- https://access.redhat.com/errata/RHSA-2018:2424
- https://access.redhat.com/errata/RHSA-2018:2425
- https://access.redhat.com/errata/RHSA-2018:2428
- https://access.redhat.com/errata/RHSA-2018:2643
- https://access.redhat.com/errata/RHSA-2018:2669
- https://access.redhat.com/errata/RHSA-2019:0877
- https://github.com/bcgit/bc-java/commit/22467b6e8fe19717ecdf201c0cf91bacf04a55ad
- https://github.com/bcgit/bc-java/commit/73780ac522b7795fc165630aba8d5f5729acc839
- https://github.com/bcgit/bc-java/wiki/CVE-2018-1000180
- https://lists.apache.org/thread.html/708d94141126eac03011144a971a6411fcac16d9c248d1d535a39451%40%3Csolr-user.lucene.apache.org%3E
Get alerted when CVE-2018-1000180 or the next vulnerability affects your stack