What’s Vulnerable › Vulnerabilities
CVE-2018-1000215
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-20 · updated 2026-06-17
- Weakness: CWE-772
Description
Dave Gamble cJSON version 1.7.6 and earlier contains a CWE-772 vulnerability in cJSON library that can result in Denial of Service (DoS). This attack appear to be exploitable via If the attacker can force the data to be printed and the system is in low memory it can force a leak of memory. This vulnerability appears to have been fixed in 1.7.7.
Affected products
- DaveGamble cJSON: through 1.7.6
References
Get alerted when CVE-2018-1000215 or the next vulnerability affects your stack